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1 Introduction

1.1 Background

This manual contains instructions on how developers can set up, run, build, and obtain updates
from the software repository for Visualization Environment for Rich Data Interpretation
(VERDI). Developers are encouraged to develop and contribute code for VERDI. Developers
are requested to submit a bugzilla request for enhancement and to submit test datasets,
documentation and proposed code to CMAS for testing prior to committing code to the
repository.

Initial development of VERDI was done by the Argonne National Laboratory for the U.S.
Environmental Protection Agency (EPA) and its user community. Argonne National
Laboratory's work was supported by the EPA though U.S. Department of Energy contract DE-
AC02-06CH11357. Further development has been performed by the University of North
Carolina Institute for the Environment under U.S. EPA Contract No. EP-W-05-045 and EP-W-
09-023, by Lockheed Corporation under U.S. EPA contract No. 68-W-04-005, and Argonne
National Laboratory. VERDI is licensed under the Gnu Public License (GPL) version 3, and the
source code is available through verdi.sourceforge.net. VERDI is supported by the Community
Modeling and Analysis System (CMAS) Center under U.S. EPA Contract No. EP-W-09-023.
The CMAS Center is located within the Institute for the Environment at the University of North
Carolina at Chapel Hill.
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2 Install developer environment

To install this software on Windows, you may need administrator privileges. You should
exit all programs before installing software.

2.1 Download and Install Eclipse

a. http://www.eclipse.org/

b. Download and install Eclipse Classic 3.5.1
i. Windows: install to the directory C:\Program Files\
ii. Linux/Mac: install to local directory

2.2 Download and install NSIS Installer (only for windows)

a. http://nsis.sf.net
b. Download NSIS installer and install
iii. install to the directory C:\Program Files\

2.3 Install Subclipse update 1.2x in Eclipse 3.5

a. http://subclipse.tigris.org/serviets/ProjectProcess?pagel D=p4wYUuA

b. Follow a link for zipped downloads:
http://subclipse.tigris.org/serviets/ProjectDocumentList?folderID=2240

c. Download the site-1.2.4.zip, Zipped update Site for Subclipse 1.2.4 (the website
states that this is obsolete, but if you use a more recent version, it will not provide
the Import>Other>Checkout Projects from SVN functionality that is needed.)

d. Extract this zip file and save into the Eclipse Directory.
a. Windows: You may need to authorize the overwriting of files.

b. Linux/Mac: copy files in Plugin directory to Plugin directory under
Eclipse.

2.4 Install Java Development Kit

a. http://java.sun.com/javase/downloads/index.jsp#jdk

b. Install the latest release of JDK that is available from the above link.

c. For Windows:
i.  Add the Java compiler to your path on the Windows Machine.
ii.  From the desktop, right-click My Computer and click Properties.
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iii.  Inthe System Properties window, click on the Advanced tab.
iv. In the Advanced section, click the Environment Variables button.

v.  Finally, in the Environment Variables window (as shown below),
highlight the Path variable in the Systems Variable section and
click the Edit button.

vi.  Add the location where the most recent JDK available on your
computer. For example: C:\Program Files\Java\jdk1.6.0_17\bin

d. For Linux
a. Add the compiler to a local directory
e. For Mac
i. JDK s already installed on OSX
a. Check version using command: javac -version
b. Check path using command: which javac
ii.  Install Java3D to support the contour plot on Mac for VERDI
a. http://www.downloadjava3d.com/mac.php

3 Running Eclipse
Start Eclipse by going to the C:\Program Files\eclipse directory and double clicking on

eclipse.exe. Specify a location for a new workspace folder, for example, C:\workspace\verdi_1.2
as is shown in Figure 3-1. Eclipse will create the directory automatically.

Figure 3-1 Select a Workspace

X)

& Workspace Launcher

Select a workspace

Eclipse S0 stores wour projects in a folder called & workspace,
Choose a workspace Folder to use For this session,

v| [ Browse...

Warkspace: | C:workspaceiverd 1.2

[JUse this as the defaul: and do not ask again

(o4 l [ Cancel
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Figure 3-2 Eclipse Starting Up

A
eclipse

GALILEO

Loading Workbench

To enter the developer workspace, click on the arrow at the right hand side of the Welcome
screen (Figure 3-3). The Eclipse workbench contains several windows to allow the user to view
source code, edit, and build within a single developer environment (Figure 3-4).

Figure 3-3 Eclipse Workbench

& Java - Eclipse SDK

File Edit Navigate Search Project Run Window Help
(%) welcome 3

5 Lok Bl
4 |
Welcome to‘ clipse
)
|

Workbench
Go to the workbench
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Figure 3-4 File Import

& Java - Eclipse SDK
#EN Edit Source Refactkor MNavigate Search Project Run Window  Help

Mew alt+shift+r - » . 2 :
) g &? @ o fg s
Open File, ..
= =0
=
& | Refresh F5
Convert Line Delimiters To r
Switch Workspace 4
Restarkt
£ Export...
Exit = :
[Zl Problems 52 @ Javadoc | [, Declaration

3.1 Import VERDI Source Code
3.1.1 Select File=>Import

To import the VERDI source code use the mouse to select File=> Import (Figure 3-5). This will
generate a pop-up window titled Import. Expand the Other Folder by clicking on the plus sign

next to the folder titled Other (Figure 3-6). On a Mac, click on T and select the SVN wizard
(Figure 3-7). Checkout Projects from SVN by clicking on it, and then click next.
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Figure 3-5 Click on Arrow to see workbench

& Java - Eclipse SDK
#EN Edit Source Refactkor MNavigate Search Project Run Window  Help

M alt+shift+r - » . 9 : = -
. : HE- @y~
Open File, ..

=0

=

& | Refresh F5

Convert Line Delimiters To r

Switch Workspace 4
Restarkt

£ Export...

Exit

[Zl Problems 52 @ Javadoc | [, Declaration

3.1.2 Checkout Projects from SVN

Select Checkout Projects from SVN and then click next (Figure 3.6 & Figure 3.7).
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Figure 3-6 Checkout Projects from SVN
on Windows/Linux

Figure 3-7 Checkout Projects from SVN on
Mac

& Import E |||:||r‘5_<|
Select \
Create a new project by checking out an existing project from a SWN I_g - 5 I
repositary,

Select an import source:

(= General

= vs

(== Plug-in Development
(= Run/Debug

(= Team

(== Cther

Checkout Projects From SWR

\
@

New

Select a wizard —

Create a new project by checking out an existing project from a SVN repository. |

Wizards:

type filter text

(& Class
¥ Interface
@Javn Project
£ Java Project from Existing Ant Buildfile
':ﬁPlug—m Project
b (= General
b CVS
b = Java
P (= Plug-in Development
¥ [ SVN
;.fcheckuut Projects from SVN
b = User Assistance

@] < Back Mext = Cancel Finish

3.1.3 Create a new repository location
Use the mouse to highlight the button next to Create a new repository location (Figure 3-6),

then click next.
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Figure 3-8 Create new repository location

& Checkout from SYN |Z|®

Select/Create Location
Select an existing repository location or create a new location, %Nl

(3) Create a new repository location:

O Use existing repository location:

@:‘ < Back " Mext >

3.1.4 Specify location of VERDI SourceForge repository

Copy and paste the url: https://verdi.svn.sf.net/svnroot/verdi then click next
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Figure 3-9 Checkout Code

£ Checkout from SVN - BX

Select/Create Location
EVN
Location
Ul | https:ffverdi svn.sfnetfsvnroot fverdi W
P

3.1.5 Select Folders for Checkout

Click on Trunk, use the mouse and the shift key to highlight the following group of subfolders:
bootstrap, core, saf.core.ui, verdi.data.loaders, and verdi_dist, then click finish (Figure 3-9).
Eclipse will checkout the latest version of VERDI from the repository. The SVN checkout
routine provides the option to run in the background, and also provides a meter indicating the
percentage of completion during the checkout process (Figure 3-10). A message will be
displayed in a console window at the bottom of the workspace if there is an error. The console
will display an error if you use a directory that already exists, and that may have permission
problems in copying files to the workspace directory. The workspace and the directory where
the VERDI software has been installed should not share the same location. Figure 3-11 shows
the code has been successfully imported into the workspace.
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Figure 3-10 Select Folders for Checkout

& Checkout from S¥YN

Select Folder
Select the folder to be checked out From SWH,

(= branches
(= tags
(= trunk

verdi_dist

< Back ][ Mext = H

Finish ] [ Cancel

Figure 3-11 SVN Checkout includes a meter indicating % completion

2 Java - Ecipse SDK_| e ] S — E=EX
File Edit Source Refactor MNavigate Search Project Run Window Help

firs- BeO-R- BB G @ PG v b i [F)
4 Package Bxp £3 . T Hierarchy| = O = 0[5z outline 52 =0

ER:

1 5§ verdi_bootstrap [trunk/bootstrap]
& g2 verdi_core

= verdi_data_loaders
122 verdi_saf_ui

An outline is not available.

& SVN Checkout =E] = ]
@ Checking out verdi.data.loaders
|
CAVERDLL2\verdi_data_loaders
[ 2] Always run in background
Run in Background| [ Cancel | [ Details>»
[ Problems 22 @ deoﬂ B Dazla.anoﬂ =08
0 items
Description = Resource Path Location  Type

SUN Checkout: (62%)

e3¢ (alpa %<
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Figure 3-12 SVN imported code into workspace

N —

= Java - Eclipse SDK

. =)

Flle Edit Navigate Search Project Run Window Help

{5 verdi_bootstrap [trunk/bootstrap]

&y verdi_core [trunk/core]

{54 verdi_data_loaders [trunk/verdi.data.lo
G verdi_dist [trunk/verdi_dist]

& verdi_saf_ui [trunk/saf.core.ui]

£ BrO-Ur EHEG ® P G E e o ()
1% Package Bp X _f2 Hierarchy| ~ O utline £ =g
B % ~ ‘An outline is not available.

[ Problems 3 @ Javadoc| (&) Declaration v =0
0 items.
Description ’ Resource Path Location  Type

Pl e

0 Building workspace: (73%) = [&a\ 0 =

4 Run VERDI within Eclipse

You can run Verdi using the Verdi.launch script in Verdi_bootstrap. Right click on
Verdi_launch, select Run As->Verdi (Figure 4-1)

UNC-Chapel Hill

Figure 4-1 Run VERDI within Eclipse

& Java - Eclipse SDK

File Edt Mavigate Search Project Run Window Help
Mew 4 =

£5 % - > o -
Show In ale+shife+w >
[ Project Explorer £3 open o
Open With v
5T verdi_bootstrap [trur| e
& src F2 Copy Qualfied Name
iy commons-logaing,| =
o pfjar 10 4/16/0] [ Paste Chri+y
oy Jpf-boot.jar 10 4| ¥ Delete Delete
o log#1.2.154ar 1| Buld Path b
=4 IRE SystemLibrar Move,..
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b Run Configuratior
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Properties
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354 werdi_core [frunijcore]
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=g verdi_dist [trunkverdi_dist]

B JRE System Library [jret]
[2 Problems 22 . @ Javador | [} Declaration

0 errors, 1,170 warnings, 0 athers (Filter matched 100 of 1170 ieems)
Resouree Path

& distib Descriptian
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5 Prepare to build Distribution

Once VERDI has been checked out of the repository, the folders will be displayed in the Project
Explorer Window on the Workbench.

5.1.1 build.properties file
5.1.1.1 Microsoft Windows

If you are building for the Windows platform, open and edit the build.properties file by double
clicking on build.properties and click on the tab labeled build.properties to see it in the text editor
(Figure 5-1). Edit the build.properties file to specify the directory where Eclipse will build the
VERDI distribution and to specify the directory where the NSIS installer software is on your
local computer.

5.1.1.2 Linux

Copy the build.properties. TEMPLATE to build.properties. Edit the build.properties file to
specify the local directory where Eclipse will build the distribution. Right click on the
build.properties file and select Save.

Figure 5-1 Review/Edit build.properties

& Java - verdi_distébuild. properties - Eclipse SDK
Eile Edit Mavigat

earch Project Run Window Help

-He  $- -0 - Q- ( BH# G- @ i H-F-=e- & | & 1va
[75 Project Explorer 51 = O[5 *buid.properties &3 =0

O G 7| #ensaag
verd_boctstrap [mkfoodtstop] # Please copy it as build.properties (in the same folder as this file),
# and change the properties as needed

# Properties for specify a local distribution directory
# app

app. name=VERDI
app.version=1.2|

.H+
e 08 QRS

ml 205 10/16/03 10:34 Al

Bib s 45 11/ 115 || D% trings - use '/’ as & separater
5] s=t ~

1 b EMPLATE 15 7/25/01 dist.dir=C:\\VERDI-dist

& Ta—j verdi_saf _ui [trunk/seF corz ] installer.home=C:\\Program FilesyyNSIS

Buldbuild. properties
[21 Problems £2 @ Javadac | [ Declaration v =8
0 errors 70 warnings, 0 others {Filter makched 100 of 1170 items)
Resource Path Locat, Type
< >
Writable: Insert 9:16 @ P HEw
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5.1.2 Build_dist.xml

The build_dist.xml provides the instructions for how to build both the Linux and Windows®
distributions of VERDI. The build_dist.xml file obtains the local directory settings from the
build.properties file. It is also possible to make the changes to specify these directories in the
build.xml, but the build.properties file has been created to clearly identify what settings are
dependent on the local directory configurations, and hopefully will reduce errors that might be
incurred by a user editing the build_dist.xml file. The section of the build_dist.xml that can be
edited to specify the local directories in this section, by commenting out the build.properties file
is shown in Figure 5-2. The section of the build_dist.xml that contains instructions to build the
linux distribution is highlighted in Figure 5-3. Figure 5-4 shows the section of the build_dist.xml
file that provides the paths for the installer used to build the Windows® distribution.

Figure 5-2 build_dist.xml — no editing needed

& Java - verdi_dist/build_dist.xml - Eclipse SDK

File Edit Mavigate Search Project Run  Window Help

-0 & i %-0- Q-  EHEG- @& G H-3-©e- T [ & 3eva |
L5 Project Explarer 52 =0 |o—ju build. properties 5] build_dist.xml 5 =0
= <'===€> = <project hawme="verdi”™ default="jars" bagedir="."» =

E_J[ werdi_bootstrap [trunk/bootstrap]

f_;‘_J, werdi_care [Frunk/core]

f_;j verdi_data_loaders [frunkverd.data.load
= Tq‘i verdi_dist [trunkverdi_dist]

<property name="

=, JRE System Library [re6] <property name="plugins.dist.dir" value="§{disc.dir}/3{plugins.dir}"/>
G4 data <property nawe="plugins.howe" wvalue="§{basedir:/.."/>
% ditfiles <property name="core.dir” wvalue="§{basedir}/../verdi core"/»
& ditlib <property name="bootstrap.dir" value="§{basedir}/../verdi_bootstrap"/>
@ bulel_distxml 205 10/16/09 10:34 AM <property name="loaders.dir” value="§{basedir}/../verdi_data loaders"/»
= i . =1 L ="rr "
build. properties 46 116/03 11:09 AM <property name sﬁf.dlr value="§{basedir}/../verdi_saf ui"/> )
build. properties. TEMPLATE 18 7/25/0 <property name="linux.disc.name" value="§{app. name}_$ {app.version} "/ >
k—j \Teer\ saf i [trunkfssF. core.ui] <property name="linux.dir” value="§{dist.dir}/linux_dist"/>
-7 ' ' <property name="versiondir"™ walue="../verdi core/src/anl/verdifutil™ />
<property name="versionbuild.dir” walue="../verdi_core/bin/anl/verdi/util™ /=

<taskdef nawme="nsis" classnawe="net.sf.nsisant.Task">
<olasspath location="./distlib/nsisant-1.2.jar"/>
</taskdef>

<path id="classpath">

<pathelement location="../verdi core/bin/" />
<fileset dir="../verdi core/lib">
<include name="**/":.jar" F- 2
PRV
E_ Problems &2 @ Javadoc @) Declaration =0
0 errors, 1,170 warnings, 0 others (Filter matched 100 of 1170 items)
Description Resource Path Locat,,,  Type

& Warnings (100 of 1170 items)

=i

Wrikable Insert 4:47 | D Ew
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Figure 5-3 build_dist.xml: build Linux distribution section

Eclipse SDK
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</target>
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/filesety
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Writable Insert 176:91
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(i) <target name="hu
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<fileset
<fileset
<fileser
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<fileser
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<fileset
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</filese
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<fileser
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</filese
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e

Elle Edit Mavigate Search Project Run  Window Help

EHEG- &S @ H
skl E2
ild.win.dist" depends="prep.dist"s

Jdistfiles/irel.6.0.zip" des §{dist.dic}"/>
Lfdiztfiles/licenses. zip" dest="§{disc.dir}"/>

"§{dist.dir} ">

file="./distfiles/run.bat"/»
file="./distfiles/verdi_launcher.nsi"/>
file="./discfilea/wverdi.nsi"/>
file="./distfiles/verdi.ini"/>
file="./distfiles/Functions.nsh"/>
file="./distfiles/config.properties"/>

file="./distfiles/shapezbin.zip"/>
file="./distfiles/RELEASE-MOTES.txt"/>

"i#{dist.dir}/data>

dir="./distfiles/data">
lude nemes=TEESET 43
L

onerror="false">

dir=r§{disc.dir} ">
lude nam FRSVERDI®.exe” />
>

ild.linux.dist” depends="prep.dist"s

writable Insert 167 : 72

B9 87 2oua |

>

@D FEw 5 B e B
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6 Build VERDI

6.1 Build using Ant

Before building the releases, a few settings have to be done through Eclipse menu options
Window->Preferences. ... Once the Preferences dialog is open (Figure 6.1), select ‘General’ then
‘Workspace’ item. In the ‘Workspace’ panel, select the check boxes for ‘Build automatically’
and ‘Refresh automatically’. Click ‘OK’ button to close the preferences dialog.

Figure 6-1 Window->Preferences

B - | 'E]

03~ B-O0-Q- EBEHFCG- S [Cd T & Java »
5 Mavigator 52 =08 =8
=& v

® 22 NETCDF4 —
2 netedra. 1 & Preferences \._|@E]

1= verdi_bootstrap [trunkfbuotstrap]

type filker text
=4 verdi_ore [trunkfcore] il Warkspace
J
) ey verdi_data Joaders [trunidverdidata b = General T
o Tegy verdi_dist [trunkfverdi_dist] *- Appearance
B T verdi_saf _ui [trunkfsaf.core.ui] Capabilties
= - Compare/Patch Build automatically
Content Types Refresh autamatically
- Editors [ 5ave automatically before build
Keys
- Metwork Connections
Perspectives wiorkspace save interval {in minutes): | S
Search
Starkup and Shutdown

Open referenced prajects when & project is apened

Web B
b Browser O lways ONever () Frompt

- Al Text File encoding New text file line defimiter
Fat Jar Preferences (® Default (Cp1252) (® Default

% Help
- TrstallUpdtes Oother: O other:

+-Java
4 Plug-in Development.
#-Run/Debug
* Team
(2 Froblems | @ Javadac | (£ Decl % 4 &) % -0
= ] verd

#-@ build-version

(@) build.win dist Restore Defaulks apply

(@) compile-version

:
:
:

@ prep.dist
@ zip

B

6.1.1 Microsoft Windows

The Windows® distribution can be built using the scripts in the distlib folder within
trunk/verdi_dist on a Windows machine. Select the eclipse menu options Window—-> Show
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View->Ant to create a subwindow for Ant (Figure 6-2). Then drag the build_dist.xml into the
Ant window. Click on the plus button next to verdi to open and display the contents.

1. Double click on build-version to label the build with the current version number
2. Double click on compile-version to compile all the source code of current version
3. Double click on build.win.dist to build the VERDI distribution for a Windows machine.

(Figure 6-3)

Figure 6-2 Window=>»Show View->Ant

& Java - Eclipse SDK

File Edit Mavigate Search Project Run RUGGGEN Help

: = : . Ty Window
il -0 Q-
) = g
i3 Package Expl &7 '[g Hierarchy Open Perspective N
=0 '

leiy verdi_bootstrap [trunkiboctstrap] Custornize Perspective. ..
{;!E‘DJ’ werdi_core [Frunk/core]
{fnj’ verdi_data_loaders [trunk/verdi daka.|
= Icgdg werdi_dist [trunk)werdi_dist]

B IRE System Library [irec]

Sawve Perspective As...
Resek Perspective. .,
Close Perspective
Close All Perspectives

(=7 data
[y distfiles Mawigation 4
i distlb Preferences

&) build_dist sl 235 11/30/09 10:28

build.properties 46 1/16/09 11:09 Al

|5 build,propetties, TEMPLATE 18 7250
{;!E‘DJ’ werdi_saf_ui [trunksaf . core,ui]
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5= Outline
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[EA Problems

@ Progress

E‘:, Project Explorer
4" search

é_'_?, Tasks
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Figure 6-3 Double click on build.win.dist to build VERDI distribution

& Java - Eclipse SDK

File Edit Mavigate Search Project Run  Window Help
il P H- 0 EHEG @Y 3 T |8 1ava |
L5 Project Explorer 52 =8 & a2 ok &7 & Q 5& = (] [+
=
Sl =
T = E
Ty werdi_boatstrap [trunk/bootstrap]
'_;& werdi_core [trunk/core]
'_;é verdi_data_loaders [trunk)verdi data.loa i "
) + -
& kg‘i werdi_disk [trunkverdi_dist] . .omp:je Fverlsmn
B JRE System Library [jre6] jars [defaul]
(5 data
5 distfiles
(5 distlib
& build_dist.xml 205 10/16/09 10:34 A
build. properties 46 1/16/09 11:02 A
|54 build.properties, TEMPLATE 15 7/25/1
Eé werdi_saf _ui [brunkysaf, core,ui]
& consoe &2 S EEEENSE e
werdi_dist build_dist. xml [Ant Build] C:\Program Files)Javaijredibintjavaw. exe (Mov 30, 2009 9:12:46 PM)
< ¥
i depends="prep. dist" © Launching verdi_dist....xml: (70%) (=€ | e ) @& #

6.1.1 Linux Distribution

Linux distribution can be built by using Ant to run build.linux.dist on a linux machine. The
trunk/verdi_dist folder contains the build_dist.xml script. In the trunk/verdi_dist/distfiles folder,
there should contain a fully unfolded jre1.6.3_13 package. Select the eclipse menu options
Window->Show View->Ant to create a subwindow for Ant (Figure 6-2). Then drag the
build_dist.xml into the Ant window. Click on the plus button next to verdi to open and display

the contents.

1. Double click on build-version to label the build with the current version number
2. Double click on compile-version to compile all the source code of current version
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3. Double click on build.linux.dist to build the VERDI distribution for a linux machine.

6.2 Check Console for Error Messages
Error messages will appear in the console underneath the Ant console.

Figure 6-4 Console Error Message

PEE 5L = =]
File Edit Mavigate Search Project Run  Window Help
3 [mil F-0-Q- EHG @A RER R B |&! ava
[ Project Explorer £2 = 0| % ant 2 oy E QXKD
O R Y| B ;‘,H\frdi ;
3 ij- werdi_bookstrap [fronkboorstrap] 4@ buid-version [
57 werdi_core [trunk/core] i frux dist
g ver .
C ‘_,jJ' verdi_data_loaders [trunk/verdi.data.loa bul\d‘.wm‘d\sF
= E& werdi_dist [Frunkfverd_dist] FDmPIIE'VE"SIDn
+ B JRE System Library [jres] Jars [defaut]
5 (®) prep.dist
= data 2@ zp
H- (g distfiles -
H-(fr distlib
<5 build_dist. sl 205 10{16/09 10:34 A
buildproperties 46 1/16/0% 11:09 AF
|53 build.properties. TEMPLATE 18 7/25/1
£ ij- werdi_saf _ui [trunkjsaf  core.ui]
EJ Conscle &2 X% GeEE =2B-r9--0
<terminated = verdi_dist build_dist. xml [ant Build] C:\Program FilestJavaljres\bin\javaw.exe (Mov 30, 2009 9:12:46 PM)
BUILD FAILED el
C:yProgram FileshVERDI 1.2%wverdi disthibuild disc.xml:31: Unable to find a javac compiler:
com.sun.tools, javac.Main is not on the classpath.
Ferhaps JAVA HOME does not point to the JDE.
It iz currently set to "C:h\Program FileshJdavah jres” a
< EAES >
: A QEW

If you obtain this error, add the Java compiler to your path on the Windows Machine (see
Section 2.2 and Section 6.2)

6.3 Add Java Compiler to Ant

To allow the Ant compiler to find the compiler, you will also need to change the Ant
Preferences to add tools.jar as an external jar as follows.
1. In Eclipse main menu select Window->Preferences (Figure 6-5)

2. In the Preference Window select Ant—>Runtime (Figure 6-6)
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3. Click on the Classpath tab, select Global Entries
4. Click on Add External JARs

5. Locate the tools.tar under the lib folder on the JDK local installation directory then click
OK, and click OK again. (Figure 6-7)

Figure 6-5 Open Windows->Preferences

& Java - Eclipse SDK r;”g‘rgl
File Edt Source Refactor Mavigate Search Project Run RUGEGEN Help

5 . . New Window

13- $-0-Q BEEG- & (&7 oe

N =5 = 8% oyt =0
[# package Explor i3 Tg Hierarchy Open Perspective N o0& Outling &3
=) <===D - Shaw View » An outling is not available,
hﬁ{ werdi_bootstrap [trunk/bootstrap] Customize Perspective. ..
J -

fy werdi_core [frunk/core] Save Perspective As. ..

{3-'& verdi_data_loaders [trunlyverdi.data. load Reset Perspective. .,

Tc'é werdi_dist [brunkfverdi_dist] Clase Perspective

hﬁj’ werdi_saf_ui [trunk/saf.core.ui] Close &ll Perspectives

Marvigation 3

[ Problems 2 @ Javadoc @) Declaration ¥ =0
54 errors, O warnings, 0 others

Description Resource Fath Locat..,  Type

@ Errors (54 items)

E_E" : Ha| O E®

oov | eclipss 1§ untitled - ... 90% | KRBELE ", sa3pm
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Figure 6-6 Expand Ant, Select Runtime, Select Global Entries

& Preferences |7 |‘E
[pereee ] Runtime G-y
General ; p
Settings used when running Ant buildfiles:
A 22 g sec wnen umina
Editn U Classpath | U] Tasks | <6 Types | < Propetties
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-~ e —
rstalfupdate " Contributed Entries Add External JARS...
Java
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RuniDebug
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Up
Down

Restore Defaults Apply
@

Figure 6-7 Add tools.tar to Ant Preferences
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Leeteiet ] Runtime

-G |
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Up
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2
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7 Updating source code from the repository

If you have previously obtained the code from the repository and want to obtain any bug fixes or
new features that developers have committed to the repository, the synchronization window
allows you to do this.

7.1 Open the Synchronization Window

Select Window->Show View-> Other to open the Show View Pop-up Window (Figure 5-1).
Expand the Team Folder by clicking on the plus symbol and then highlight the word
Synchronize and click OK (Figure 7-2).

Figure 7-1 Show View = Other

& Java - Eclipse SDK
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k_fﬁ verdi_launcher.nsi 196 10709 10 [ Templates
W werdiini 156 9/28/09 159 PM qur
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Figure 7-2 Expand Team Folder - highlight Synchronize — click ok

— Java - Eclipse SDK

File Edit Mavigate Search Project Run  Window Help
Ci- [ -0 EHEG- @YY
] Package Explor &2 Tg Hierarchy\l =0

BE Y

& Show View

k‘cji werdi_boatstrap [trunk/bookstrap]

1=% werdi_core

h:'é verdi_data_loaders [trunk verdi.data. load
Bkﬁ werdi_dist [Erunkverdi_dist]

B IRE System Library [irec]

| bype filker bext

= dava
: (5 data [ Java Browsing
=y distfiles (= Plug-in Development

=% data

: |:=E, config.properties 96 4/2/09 11:13
----- (Tﬁ Functions.nsh 2 416008 11:49 AR
----- Ed. jrel.6.0.zip 94 40209 506 PM qu
----- kﬂ, licenses.zip 18 7/25(08 11:24 AM
""" E’E. RELEASE-MOTES kxt 239 12/1/02
@ run.bat 165 5/29/09 6:24 PM qur
----- Eﬂ, shapezbin.zip 141 S/20/09 556 F
----- (34 werdi_Jauncher.nsi 196 10/7/09 10
----- _E werdiini 156 9/28[09 1:59 PM qur
0 werdinsi 196 10/7/09 10:33 PM g
----- |5 werdish 224 11/23/09 1112 FM o
[y distlib

""" 5@ build_dist. el 235 11/30/0% 100258 PM
y build. properties 46 1716/09 11:09 AM
----- |53 build,properties, TEMPLATE 18 7/25/0¢

RN
EQ_, Pending SYN Operations
Gk, VN Annotate

&; SYM Properties

SYM Repositary

= SYN Resource History

W

Use F2 to display the description For a selected view,

L K ] [ Cancel

Figure 7-3 Synchronize Window added to bottom of Workspace
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7.2 Synchronize with Repository using SVN
The Synchronize window contains a synchronize symbol at the upper right corner. Click on the
synchronize symbol to open the Synchronize popup window. Click on SVN to select the
subversion software package manager, then click NEXT. A Synchronize SVN pop-up window
will appear listing the packages that are available as resources for synchronization. Click the
Select All button to select all the packages, then click FINISH. A pop-up window labeled
Confirm Open Perspective will ask if you would like to change from the Java Perspective to the
Team Synchronization Perspective. If you opt to change perspectives, there is a right arrow
button in the upper right hand corner of the workspace to switch back to the Java Perspective
once you are finished reviewing the code in the Team Synchronization Perspective.

Figure 7-4 Click on Synchronize Symbol to bring up Pop-up
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Figure 7-5 Synchronize Pop-up — select SVN
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7.3 Resolve conflicts and Update

After synchronization, there will be a blue incoming arrow at the bottom of eclipse window that
reports the number of files on the repository that are different than your local workspace, a green
outgoing arrow, and red double conflict arrow. If you click on the blue arrow, and then right
click on the Verdi_core, a pop-up menu will allow you to select update, to bring the updates to
the code down to your local workspace (see Figure 7-8).

Figure 7-7 Check for Updates and Conflicts
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Figure 7-7 Check for Updates and Conflicts
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& CVS Repository Exploring - verdi_dist/build_dist.xml - Eclipse SDK
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