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1 Introduction 

1.1 Background  

This manual contains instructions on how developers can set up, run, build, and obtain updates 

from the software repository for Visualization Environment for Rich Data Interpretation 

(VERDI).   Developers are encouraged to develop and contribute code for VERDI.  Developers 

are requested to submit a bugzilla request for enhancement and to submit test datasets, 

documentation and proposed code to CMAS for testing prior to committing code to the 

repository. 

Initial development of VERDI was done by the Argonne National Laboratory for the U.S. 

Environmental Protection Agency (EPA) and its user community. Argonne National 

Laboratory's work was supported by the EPA though U.S. Department of Energy contract DE-

AC02-06CH11357.  Further development has been performed by the University of North 

Carolina Institute for the Environment under U.S. EPA Contract No. EP-W-05-045 and EP-W-

09-023, by Lockheed Corporation under U.S. EPA contract No. 68-W-04-005, and Argonne 

National Laboratory.  VERDI is licensed under the Gnu Public License (GPL) version 3, and the 

source code is available through verdi.sourceforge.net.  VERDI is supported by the Community 

Modeling and Analysis System (CMAS) Center under U.S. EPA Contract No. EP-W-09-023. 

The CMAS Center is located within the Institute for the Environment at the University of North 

Carolina at Chapel Hill. 
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2 Install developer environment 

To install this software on Windows, you may need administrator privileges.  You should 

exit all programs before installing software. 

2.1 Download and Install Eclipse 

a. http://www.eclipse.org/ 

b. Download  and install Eclipse Classic 3.5.1 

i. Windows: install to the directory C:\Program Files\ 

ii. Linux/Mac: install to local directory 

2.2 Download and install NSIS Installer (only for windows) 

a. http://nsis.sf.net 

b. Download NSIS installer and install 

iii. install to the directory C:\Program Files\ 

2.3 Install Subclipse update 1.2x in Eclipse 3.5 

a. http://subclipse.tigris.org/servlets/ProjectProcess?pageID=p4wYuA 

b. Follow a link for zipped downloads: 

http://subclipse.tigris.org/servlets/ProjectDocumentList?folderID=2240 

c. Download the site-1.2.4.zip, Zipped update Site for Subclipse 1.2.4 (the website 

states that this is obsolete, but if you use a more recent version, it will not provide 

the Import>Other>Checkout Projects from SVN functionality that is needed.) 

d. Extract this zip file and save into the Eclipse Directory.   

a. Windows: You may need to authorize the overwriting of files. 

b. Linux/Mac: copy files in Plugin directory to Plugin directory under 

Eclipse. 

2.4 Install Java Development Kit 

a. http://java.sun.com/javase/downloads/index.jsp#jdk 

b. Install the latest release of JDK that is available from the above link. 

c. For Windows:  

i. Add the Java compiler to your path on the Windows Machine.  

ii. From the desktop, right-click My Computer and click Properties.  

http://www.eclipse.org/
http://nsis.sf.net/
http://subclipse.tigris.org/servlets/ProjectProcess?pageID=p4wYuA
http://subclipse.tigris.org/servlets/ProjectDocumentList?folderID=2240
http://java.sun.com/javase/downloads/index.jsp#jdk
http://www.computerhope.com/jargon/d/desktop.htm
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iii. In the System Properties window, click on the Advanced tab.  

iv. In the Advanced section, click the Environment Variables button. 

v. Finally, in the Environment Variables window (as shown below), 

highlight the Path variable in the Systems Variable section and 

click the Edit button.  

vi. Add the location where the most recent JDK available on your 

computer. For example: C:\Program Files\Java\jdk1.6.0_17\bin 

d.  For Linux 

a. Add the compiler to a local directory 

e. For Mac 

i. JDK is already installed on OSX 

a. Check version using command: javac –version 

b. Check path using command: which javac 

ii. Install Java3D to support the contour plot on Mac for VERDI 

a. http://www.downloadjava3d.com/mac.php  

3 Running Eclipse 

Start Eclipse by going to the C:\Program Files\eclipse directory and double clicking on 

eclipse.exe.  Specify a location for a new workspace folder, for example, C:\workspace\verdi_1.2 

as is shown in Figure 3-1.  Eclipse will create the directory automatically. 

Figure 3-1 Select a Workspace 

 
 

http://www.computerhope.com/jargon/w/window.htm
http://www.computerhope.com/jargon/t/tab.htm
http://www.computerhope.com/jargon/p/pushbutt.htm
http://www.downloadjava3d.com/mac.php
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Figure 3-2 Eclipse Starting Up 

 
 

 

To enter the developer workspace, click on the arrow at the right hand side of the Welcome 

screen (Figure 3-3).  The Eclipse workbench contains several windows to allow the user to view 

source code, edit, and build within a single developer environment (Figure 3-4). 

Figure 3-3 Click on Arrow to see workbench 
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Figure 3-4 Workbench – Developer Environment 

 
 

3.1 Import VERDI Source Code 

3.1.1 Select File>Import 

To import the VERDI source code use the mouse to select File>Import (Figure 3-5). This will 

generate a pop-up window titled Import.  Expand the Other Folder by clicking on the plus sign 

next to the folder titled Other (Figure 3-6).  On a Mac, click on  and select the SVN wizard 

(Figure 3-7). Checkout Projects from SVN by clicking on it, and then click next. 

Figure 3-5 Import VERDI Source Code 
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3.1.2 Checkout Projects from SVN 

Select Checkout Projects from SVN and then click next (Figure 3.6). 

Figure 3-6 Checkout Projects from SVN 

on Windows/Linux 

Figure 3-6 Checkout Projects from SVN on 

Mac 

 

 

3.1.3 Create a new repository location 
Use the mouse to highlight the button next to Create a new repository location (Figure 3-6), 

then click next. 
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Figure 3-7 Create new repository location 

 

 

3.1.4 Specify location of VERDI SourceForge repository 

Copy and paste the url: https://verdi.svn.sf.net/svnroot/verdi then click next 

https://verdi.svn.sf.net/svnroot/verdi
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Figure 3-8 Checkout Code 

 
 

3.1.5 Select Folders for Checkout 

Click on Trunk, use the mouse and the shift key to highlight the following group of subfolders: 

bootstrap, core, saf.core.ui, verdi.data.loaders, and verdi_dist, then click finish (Figure 3-9).  

Eclipse will checkout the latest version of VERDI from the repository.  The SVN checkout 

routine provides the option to run in the background, and also provides a meter indicating the 

percentage of completion during the checkout process (Figure 3-10). A message will be 

displayed in a console window at the bottom of the workspace if there is an error. The console 

will display an error if you use a directory that already exists, and that may have permission 

problems in copying files to the workspace directory.  The workspace and the directory where 

the VERDI software has been installed should not share the same location.  Figure 3-11 shows 

the code has been successfully imported into the workspace. 
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Figure 3-9 Select Folders for Checkout 

 

 

Figure 3-10 SVN Checkout includes a meter indicating % completion 
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Figure 3-11 SVN imported code into workspace 

 

4 Run VERDI within Eclipse 

You can run Verdi using the Verdi.launch script in Verdi_bootstrap.  Right click on 

Verdi_launch, select Run As>Verdi (Figure 4-1) 

Figure 4-1 Run VERDI within Eclipse 
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5 Prepare to build Distribution  

Once VERDI has been checked out of the repository, the folders will be displayed in the Project 

Explorer Window on the Workbench. 

5.1.1 build.properties file 

5.1.1.1 Microsoft Windows 

If you are building for the Windows platform, open and edit the build.properties file by double 

clicking on build.properties and click on the tab labeled build.properties to see it in the text editor 

(Figure 5-1).  Edit the build.properties file to specify the directory where Eclipse will build the 

VERDI distribution and to specify the directory where the NSIS installer software is on your 

local computer.   

5.1.1.2 Linux 

Copy the build.properties.TEMPLATE to build.properties.  Edit the build.properties file to 

specify the local directory where Eclipse will build the distribution.  Right click on the 

build.properties file and select Save. 

Figure 5-1 Review/Edit build.properties 
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5.1.2 Build_dist.xml 

The build_dist.xml provides the instructions for how to build both the Linux and Windows® 

distributions of VERDI. The build_dist.xml file obtains the local directory settings from the 

build.properties file.  It is also possible to make the changes to specify these directories in the 

build.xml, but the build.properties file has been created to clearly identify what settings are 

dependent on the local directory configurations, and hopefully will reduce errors that might be 

incurred by a user editing the build_dist.xml file.  The section of the build_dist.xml that can be 

edited to specify the local directories in this section, by commenting out the build.properties file 

is shown in Figure 5-2.  The section of the build_dist.xml that contains instructions to build the 

linux distribution is highlighted in Figure 5-3.  Figure 5-4 shows the section of the build_dist.xml 

file that provides the paths for the installer used to build the Windows® distribution. 

Figure 5-2 build_dist.xml – no editing needed 
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Figure 5-3 build_dist.xml: build Linux distribution section 

 

Figure 5-4 dist.xml: nsis installer path section 
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6 Build VERDI 

 

6.1 Build using Ant 

6.1.1 Microsoft Windows 

The Windows® distribution can be built using the scripts in the distlib folder within 

trunk/verdi_dist on a Windows machine.  Select the eclipse menu options Window>Show 

View>Ant to create a subwindow for Ant (Figure 6-1).  Then drag the build_dist.xml into the 

Ant window.  Click on the plus button next to verdi to open and display the contents.   

 

1. Double click on build-version to label the build with the current version number 

2. Double click on compile-version to label the compiler version 

3. Double click on build.win.dist to build the VERDI distribution for a Windows machine. 

(Figure 6-2) 

 

Figure 6-1 Window>Show View>Ant 
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Figure 6-2 Double click on build.win.dist to build VERDI distribution 

 

 
 

 

6.1.1 Linux Distribution 

Linux distribution can be built by using Ant to run build.linux.dist on a linux machine.  The 

trunk/Verdi_dist folder contains the build_dist.xml script.  Select the eclipse menu options 

Window>Show View>Ant to create a subwindow for Ant (Figure 6-1).  Then drag the 

build_dist.xml into the Ant window.  Click on the plus button next to verdi to open and display 

the contents.   
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1. Double click on build.linux.dist to build the VERDI distribution for a linux machine. 

6.2 Check Console for Error Messages 
Error messages will appear in the console underneath the Ant console. 

Figure 6-3 Console Error Message 

 

If you obtain this error, add the Java compiler to your path on the Windows Machine (see 

Section 2.2 and Section 6.2) 

6.3 Add Java Compiler to Ant 

To allow the Ant compiler to find the compiler, you will also need to change the Ant 

Preferences to add tools.jar as an external jar as follows. 

1. In Eclipse main menu select Window>Preferences (Figure 6-3) 

2. In the Preference Window select Ant>Runtime (Figure 6-4) 
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3. Click on the Classpath tab, select Global Entries 

4. Click on Add External JARs 

5. Locate the tools.tar under the lib folder on the JDK local installation directory then click 

OK, and click OK again. (Figure 6-5) 

Figure 6-4 Open Windows>Preferences 
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Figure 6-5 Expand Ant, Select Runtime, Select Global Entries 

 

 

Figure 6-6 Add tools.tar to Ant Preferences 

 

7 Updating source code from the repository 
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7.1 Open the Synchronization Window 

Select Window>Show View>Other to open the Show View Pop-up Window (Figure 5-1).  

Expand the Team Folder by clicking on the plus symbol and then highlight the word 

Synchronize and click OK (Figure 7-2). 

Figure 7-1 Show View > Other 
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Figure 7-2 Expand Team Folder - highlight Synchronize – click ok 

 

Figure 7-3 Synchronize Window added to bottom of Workspace 
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7.2 Synchronize with Repository using SVN 
The Synchronize window contains a synchronize symbol at the upper right corner.  Click on the 

synchronize symbol to open the Synchronize popup window.  Click on SVN to select the 

subversion software package manager, then click NEXT.  A Synchronize SVN pop-up window 

will appear listing the packages that are available as resources for synchronization.  Click the 

Select All button to select all the packages, then click FINISH.  A pop-up window labeled 

Confirm Open Perspective will ask if you would like to change from the Java Perspective to the 

Team Synchronization Perspective.  If you opt to change perspectives, there is a right arrow 

button in the upper right hand corner of the workspace to switch back to the Java Perspective 

once you are finished reviewing the code in the Team Synchronization Perspective. 

Figure 7-4 Click on Synchronize Symbol to bring up Pop-up 
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Figure 7-5 Synchronize Pop-up – select SVN 

 

Figure 7-6 Synchronize SVN – select all 
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Figure 7-7 Alternate way to update from repository 

 

 

 


